欢迎光临精准像素,本站所有资源仅供学习与参考,禁止用于商业用途或从事违法行为!

wordpress教程

WordPress判断浏览器版本,低版本浏览器提示升级

wordpress教程 精准像素 2021-03-08 共30人阅读

使用低版本的浏览器的用用户还是很多的,但是对于开发者来说,低版本的浏览器简直就是噩梦般的存在,主动去兼容低版本浏览器成本又太高。

所以为了更好兼容低版本浏览器用户,我们最好能给提示,让用户升级浏览器。

在提示之前我们需要获取到浏览器版本,WordPress有自带的获取方法,判断访问者用浏览器,然后提醒用户升级浏览器,或者调用不同的样式。

<?php
global $is_IE;
if ($is_IE) {
echo '您正在使用不安全的IE浏览器,请使用现代浏览器,浏览本站,以获得最佳体验!';
}
?>

当有人用IE访问网页时,显示提示信息,用IE访问WP后台时也会有类似提示。

如果想针对其它浏览器,可以参照下面的变量,以此类推。

$is_iphone (boolean) iPhone Safari
$is_chrome (boolean) Google Chrome
$is_safari (boolean) Safari
$is_NS4 (boolean) Netscape 4
$is_opera (boolean) Opera
$is_macIE (boolean) Mac Internet Explorer
$is_winIE (boolean) Windows Internet Explorer
$is_gecko (boolean) FireFox
$is_lynx (boolean)
$is_IE (boolean) Internet Explorer
$is_edge (boolean) Microsoft Edge